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Excel Basics
Shortcuts for Getting Around
To do this
Go to column A of the active row
Go to the edge of the spreadsheet
Go to cell A1 of the active worksheet
Go to last cell of the spreadsheet data
Scroll one window up or down
Scroll one window left or right
Move among the four corners of the selected range
Go to a specified cell
Move one column to the left or right.
Move one row up or down.
Move between noncontiguous selected ranges

Press
HOME
END+ arrow
CTRL+HOME
CTRL+END
PAGEUP OR PAGEDOWN
ALT+PAGEUP OR PAGEDOWN
CTRL+.
Click the Name box, type the cell reference you want to go to and press ENTER
LEFT ARROW or RIGHT ARROW
UP ARROW or DOWN ARROW
CTRL+ALT+LEFT ARROW or RIGHT ARROW
Select

Know Your Mouse Cursors

Text

AutoFill
Handle

Select – Your cursor will be the white cross when you move the mouse cursor to the
middle of a cell. This cursor is for selecting.
Copy
Move - Move the mouse cursor to the edge of a cell and get an arrow. This cursor is for
Move
moving (a.k.a. drag-and-drop).
Copy - When the mouse cursor is at the lower-right corner of the cell selector over the black dot (AutoFill Handle), you get the black
cross for copying the cell contents or using fill series.
Text - The I-beam cursor indicates you are in a text area for typing. Then only time you will see the I-beam cursor in a cell is when it is
in edit mode. You are in edit mode if the Formula bar displays a red X and green 9.

Select Exactly What You Want
To select
The contents of a cell
A single cell
A range of cells
A large range of cells
Nonadjacent cells or
cell ranges
An entire row or
column

Do this
Double-click the cell (or press F5), and then select the contents of the cell or select the cell, and then select the
.
contents of the cell in the formula bar
Click the cell, or press the arrow keys to move to the cell.
Click the first cell in the range, and then drag to the last cell, or hold down SHIFT while you use the arrow
keys to extend the selection.
Click the first cell in the range, and then hold down SHIFT while you click the last cell in the range. You can
scroll to make the last cell visible.
Select the first cell or range of cells, and then hold down CTRL while you select the other cells or ranges.
 You cannot cancel the selection of a cell or range of cells in a nonadjacent selection without canceling the
entire selection.
Click the row or column heading.
Column Heading
Row Heading
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To select
Do this
All cells on a worksheet Click the Select All button.

To select the entire worksheet, you can also press CTRL+A.  If the
worksheet contains data, CTRL+A selects the current region. Pressing
Select All
CTRL+A a second time selects the entire worksheet.
Adjacent rows or
Drag across the row or column headings. Or select the first row or column; then hold down SHIFT while you
columns
select the last row or column.
Nonadjacent rows or
Click the column or row heading of the first row or column in your selection; then hold down CTRL while
columns
you click the column or row headings of other rows or columns that you want to add to the selection.
More or fewer cells than Hold down SHIFT and click the last cell that you want to include in the new selection. The rectangular range
the active selection
between the active cell and the cell that you click becomes the new selection.

Work with Worksheets
To select
A single worksheet

Do this
Click the sheet tab. If you don't see the tab you want, click the tab
scrolling buttons to display the tab OR right-click the tab scrolling
buttons for a list of worksheets, . and then click the tab

Tab scrolling buttons

The next worksheet
CTRL+PAGEDOWN
The previous worksheet
CTRL+PAGEUP
Two or more adjacent worksheets
Click the tab for the first, and then hold down SHIFT and click the tab for the last sheet.
Two or more nonadjacent worksheets Click the tab for the first, and then hold down CTRL and click the tabs for the other sheets.
All sheets in a workbook
Right-click a sheet tab, and then click Select All Sheets.
Cancel a selection of multiple
Click any unselected worksheet. If no unselected sheet is visible, right-click the tab of a
worksheets in a workbook
selected sheet, and then click Ungroup Sheets on the shortcut menu
*When multiple worksheets are selected, [Group] appears in the title bar at the top of the worksheet. Data that you enter or edit in the
active sheet is reflected in all selected sheets. These changes may replace data on the active sheet and, perhaps inadvertently, on other
selected sheets.
To do this
Add Color to Sheet Tabs

Do this
1. Select the sheets you want to color.
2. On the Format menu, point to Sheet, and then click Tab Color OR right-click on the
sheet tab and then click Tab Color.
3. Click on the color you want and click OK .

Delete Sheets

1.
2.
1.

Insert a New Worksheet(s)

Rename a Worksheet

Move or Copy Sheets
 To move sheets within the current
workbook, drag the selected sheets along the
row of sheet tabs. To copy the sheets, hold
down CTRL, and then drag the sheets; release
the mouse button before you release CTRL.
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Select the sheet(s) you want to delete.
On the Edit menu, click Delete Sheet OR right-click the sheet tab and then click Delete.
Select the same number of existing worksheet tabs that you want to add. (i.e.: If you want
to add three new worksheets, select three existing worksheet tabs.)
2. Click Worksheet on the Insert menu.
1. On the Format menu, point to Sheet and then click Rename OR right-click the tab to
rename, and then click Rename OR double-click the tab to rename.
2. Type the new name over the current name.
3. Press ENTER.
1. To move or copy to another workbook, open the workbook that will receive the sheets.
2. Switch to the workbook that contains the sheets you want to move or copy, and then
select the sheets.
3. On the Edit menu, click Move or Copy Sheet.
4. In the To book box, click the workbook to receive the sheets.
To move or copy the selected sheets to a new workbook, click new book.
5. In the Before sheet box, click the sheet before which you want to insert the moved or
copied sheets.
6. To copy the sheets instead of moving them, select the Create a copy check box.
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To do this
Display or Hide All Sheet Tabs

Do this
1. On the Tools menu, click Options.
2. On the View tab, under Window options, select or clear the Sheet tabs check box.
Make More or Fewer Sheet Tabs Visible 1. Point to the tab split bar on the right side of the Sheet tab bar.
2. When the pointer changes to a split pointer , drag the tab
split bar to the right or left.
3. To return the tab split bar to its original position, double-click the tab split bar.

Edit a Worksheet
Edit Cells
To do this
Enter data into a cell
Enter data in a range of cells

Delete the contents of a cell
Delete the cell
Copy the contents of the cell above
Enter the current date
Enter the current time

Do this
Select the cell and type your entry (you’ll be in edit mode) and then press ENTER or click
on the Formula bar to confirm the entry.
Select the range. When you type, your entry will be entered into the active (white) cell. To
move from cell to cell, use TAB, SHIFT+TAB, ENTER, and SHIFT+ENTER to remain within
the selected range.
Select the cell and press DELETE
Select the cell and go to the Edit menu and select Delete… The Delete dialog box will open.
Choose which way to shift the remaining cells or delete the entire row or column.
CTRL+’ (apostrophe)
CTRL+; (semicolon)
CTRL+: (colon)

Edit Rows or Columns
To do this
Insert a row or column

Do this
Right-click the row or column heading and select Insert OR select the row(s) or column(s)
and go to the Insert menu and select Rows or Columns. Select multiple rows or columns to
insert the same number selected.
Delete a row or column
Right-click the row or column heading and select Delete OR select the row(s) or column(s)
and go to the Edit menu and select Delete OR press CTRL+- (hyphen).
Resize the row or column*
Drag the right or bottom margin of the row or column headings with your mouse OR go to
the Format menu and select Row or Column (choose AutoFit Selection to fit to the size of
the largest entry you have selected)..
* Resize the row or column to the widest entry by double-clicking the bottom or right margin in the headings.
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How Formulas Work
If a formula cannot properly calculate a result, Microsoft Excel will display an error code.
Error Code
Explanation
######
The result is too long to fit in the cell. Adjust the column width.
#VALUE!
Wrong type of argument or operand used, or the Formula AutoCorrect cannot correct the formula.
#DIV/0!
You are dividing by zero. Check and correct the divisor.
#NAME?
Excel doesn’t recognize a name. Check the spelling of the function name or such a function exists.
#N/A
Occurs when a value is not available to a function or formula.
#REF!
A cell reference is not valid. You may have deleted named cells referred to in the formula.
#NUM!
There is a problem with a number in a formula or function.
#NULL!
You specified an intersection of two areas that don’t intersect.
Cannot resolve
Appears in a dialog box if you use the address of the active cell in the formula you enter.
circular references

Create a Basic Formula
Formulas are equations that perform calculations on values in your
worksheet. A formula starts with an equal sign (=) and do not include spaces.
1.
2.
3.
4.

Valid mathematical operators
+ Addition
*
- Subtraction
/

Multiplication
Division

Click the cell in which you want to enter the formula.
, type = (equal sign).
In the formula bar
Type the formula using mathematical rules and operators. Values may be typed or be a cell reference.
To create a reference, select a cell or a range of cells (or type the cell reference or range).
Press ENTER.

Use Functions
Syntax: =FunctionName(arguments)
All arguments must be enclosed in parenthesis with no spaces.
Use the colon (:) to indicate a range of cells and a comma (,) to
separate arguments.
1. Click the cell in which you want to enter the formula.
2.
3.
4.

on the Formula bar.
Select Insert Function
Select the category from the drop-down list, then select
the function name and click OK .
Complete the necessary arguments by typing the cell or
cell ranges OR follow steps below.
(Arguments in bold are required.)
a.
b.
c.

Click Collapse
and select the cell (range).
Click Expand
to return to the help box and
continue for arguments necessary.
Click OK when finished.

EXAMPLES
=SUM(range) Adds all the values for the specified cells.
=AVERAGE(range) Returns the average value of all the cells
specified.
=MIN(range) Returns the lowest value of all the cells specified.
=MAX(range) Returns the highest value of all the cells
specified.
=COUNT(range) Returns the number of cells containing
numeric information. Empty cells, logical values, text, or
error values in the array or reference are ignored.
=COUNTA(range) (Count All) Returns the number of cells
containing information. Empty cells are ignored.
=TODAY() or =NOW()
TODAY returns today’s date as mm/dd/yy.
NOW returns the date and time.

Use the Status Bar to Calculate
As you select the numbers, Excel automatically calculates them in the status bar. To change the function, right-click the status bar and
choose the function you need. You have a choice of Average, Count, Count Nums, Max, Min and Sum.
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Understand and Use AutoSum
1.

Select the cell(s) where the results of the formula will display

2.

Click AutoSum
on the Standard toolbar OR press ALT+= (equal).
Other functions include Average, Count, Maximum and Minimum.

Use AutoFill or the Fill Commands
1.
2.

Select the cell to copy, and then grab the AutoFill handle (lower-right corner of cell selector) and drag.
Select the cell to copy and the contiguous cells to copy it to. Go to the Edit menu and select Fill, and then choose the direction
you’d like to fill. You can use CTRL+R to fill right and CTRL+D to fill down.

Create Absolute References
Press F4 immediately after you type a cell reference in a formula to make it absolute OR type the dollar signs ($) in front of the column
and row reference when you enter the cell reference. i.e. =AVERAGE(F9:$F$13)

Name a Cell or Range
1. Select the cell(s) you’d like to name
2. Click the Name box at the left end of the formula bar.
3. Type a name and press ENTER.
Generate a list of all named ranges in a workbook,
1. Select a cell in a blank area in the workbook.
2. From the Insert menu, go to Name and select Paste.
3. When the Paste Name dialog box appears, click Paste List .
Name box

Change or Delete a Defined Name
1.
2.

On the Insert menu, point to Name, click Define.
In the Names in workbook list, click the name you
want to change.
3a. Change the name
1. Type the new name for the reference, and then
click Add.
2. Click the original name, and then click Delete.
3b. Change the cell, formula, or constant represented by
a name by changing it in the Refers to box.
3c. Delete the name by clicking Delete.

Format Cells and the Worksheet
Format Cells
Use the Formatting toolbar to format the text font, style, color, etc. Use the Borders toolbar to format the cell border/grid.
From the Format menu, select Cells… OR CTRL+1 to open the Format Cells dialog box.

Copy and Apply Cell Formatting
SmartTag
1.

Select the cell(s) with the formatting to copy.

2.
3.

Click Copy
(CTRL+C) on the Standard toolbar.
Select the cell(s) to have the formatting applied to.

4.
5.

Click Paste
(CTRL+V) on the Standard toolbar. Paste Options
Click the Paste Options button, and choose the appropriate option.
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Paste Special
1.

Select the cell(s) with the formatting to copy.

2.
3.
4.

(CTRL+C) on the Standard toolbar.
Click Copy
Select the cell(s) to have the formatting applied to.
From the Edit menu, select Paste Special… OR rightclick the selection and select Paste Special…
Select Formats then click OK .

5.

AutoFill Handle
1.
2.

Select the cell(s) that contains the formatting to copy.
Using the RIGHT mouse button, grab the AutoFill
handle and drag across the cells to be formatted.
3. Select Fill Formatting Only from the shortcut menu
that appears after you release the mouse button.
SmartTag Option
Auto Fill Options appears just below your filled
selection after you fill text or data in a worksheet. When
you click the button, a list appears to give you options
for how to fill the text or data.

Format Painter
1.

Select the cell(s) with the formatting to copy.

2.

Click Format Painter
(CTRL+SHIFT+C) on the
Standard toolbar to turn it on. Double-click the button
is you’d like it to remain on for multiple applications.
Select the cell(s) you’d like to have the formatting
applied to (CTRL+SHIFT+V).

3.

Create Your Own Style
1.
2.
3.
4.
5.
6.
7.

Select the cell(s) with the formatting to style.
From the Format menu, select Style…
In the Style Name provide a name for your style then
click Add to define the style.
Click Close when finished.
To apply a style, select the cell(s) you’d like to have the
style applied to.
From the Format menu, select Style…
Select the style from the drop-down list then click OK .

Let Excel Format the Spreadsheet for You
1.
2.

Select the spreadsheet to format and then go to the Format menu and select AutoFormat…
Choose a style and click OK .

Find and Replace
Find
1.
2.

3.

Replace

From the Edit menu, select Find OR press CTRL+F.
Type the word or phrase you’re looking for and press ENTER.
Excel will find all occurrences of the word or phrase. If the first
occurrence is not the one you’re looking for, select Find Next
to keep looking.
If you’re not looking for a word or phrase but a specific format,
in the Find dialog box, select Format…b . You can locate a
specific format or select Choose Format from Cell… then
click the cell with the formatting you’d like to find.

1.
2.
3.

4.

From the Edit menu, select Replace OR press CTRL+H.
In the Find what: field, type the word or select the format
to replace.
In the Replace with: field, type what it will be replaced with
(if you don’t type anything here, it will delete all
occurrences throughout your document).
You may either select Find Next and replace each
occurrence one-by-one, or select Replace All to have it all
done at once.

Preview and Print
Set Print Options
Go to the File menu and select Page Setup OR from Print Preview, click Setup .
• SELECT A PRINT AREA — select the area to print and go to the File menu and select Print Area then Set Print Area OR go
to the File menu and select Page Setup, click the Sheet tab and define the print area under Print area:
•
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click Margins then click and drag a margin to adjust OR from the Page Setup dialog
SET MARGINS — Print Preview
box on Margins tab, select the exact measurements for the top, bottom, left, right, header and footer.
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Create Headers and Footers
1.
2.

3.

Go to the File menu and select Page Setup
&[Page] = Page Number
OR from Print Preview, click Setup .
&[Pages] = Total Pages
On the Header/Footer tab, choose an option
from the drop-lists or choose to create a
&[Date] = Date
Custom Header… or Custom Footer…
&[Picture] = Image
Click a section to place your cursor and
either type your text or use one of the tools to insert a field code.
a. Select the text or field code(s) to format, and then click Format Font
b.

Select the &[Picture] field code, then click Format Picture

&[Time] = Time
&[File] = File Name
&[Tab] = Sheet Name
&[Path]&[File] = Path & file name
to format the text font, style, etc.

to format the image.

Open another File Type in Excel
1.
2.
3.
4.

From the File menu, select Open… or click Open
on the Standard toolbar.
Change the Files of type: to All Files at the bottom of the window.
In the Look in list, click the drive, folder, or Internet location that contains the file you want to open.
Select the file to open and click Open .

Save a Workbook in another File Format
1.
2.
3.
4.
5.

Open the workbook you want to save for use in another program.
On the File menu, click Save As.
In the File name box, type a new name for the workbook.
In the Save as type list, click a file format that you know you can open in the other program.
Click Save .

Use E-mail Features
Go to the File menu, then Send to ` Mail Recipient (as attachment) to sent the workbook as an attachment in a Notes mail message.
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Excel Practice Exercise
Create a New Workbook
1.
2.
3.
4.
5.
6.
7.
8.

Create a new Workbook in Microsoft Excel.
Save as: Flora’s Flowers
Rename Sheet1 to 1st Week
Rename Sheet2 to 2nd Week
Rename Sheet3 to 3rd Week
Insert two new worksheet and rename to 4th Week and 5th Week
Move 4th Week and 5th Week behind 3rd Week worksheet
Enter data on 1st Week worksheet:

E
F
A
B
C
D
G
1 Products Monday
Tuesday
Wednesday Thursday
Friday
Total
317
326
2 Roses
352
276
297
132
114
3 Pansies
153
126
111
79
95
4 Mums
98
112
87
5 Total
Insert a new row before the Total row and name it Daisies
with the following data: 56, 62, 47, 49, 53
10. Resize rows and/or columns as needed.
11. SAVE!

9.

Create a Formula
1.
2.
3.
4.

Sum the days (columns) and products (rows).
In column H, add the heading Average and average each product for the week.
In column I, add the heading Percent and find the percent of sales for each product.
SAVE!

Format the Spreadsheet
1.
2.
3.
4.

Format the first and last rows as currency and the remaining rows with comma style.
Format the percent column as a percent.
Format the spreadsheet with color, borders, shading, etc. (AutoFormat)
SAVE!

Print Options
1.
2.
3.
4.
5.
6.

Print preview the spreadsheet.
Set up margins, layout and scaling.
Create a header with the workbook’s name and worksheet’s name.
Create a footer with the date the report was printed.
Print preview the spreadsheet.
SAVE!

Excel Practice Exercise
Create a New Workbook
1.
2.
3.
4.
5.
6.
7.
8.

Create a new Workbook in Microsoft Excel.
Save as: Flora’s Flowers
Rename Sheet1 to 1st Week (double-click worksheet tab, type name and then press ENTER)
Rename Sheet2 to 2nd Week (double-click worksheet tab, type name and then press ENTER)
Rename Sheet3 to 3rd Week (double-click worksheet tab, type name and then press ENTER)
Insert two new worksheet and rename to 4th Week and 5th Week (From the Insert menu, select Worksheet)
Move 4th Week and 5th Week behind 3rd Week worksheet (drag-and-drop)
Enter data on 1st Week worksheet:

E
F
A
B
C
D
G
1 Products Monday
Tuesday
Wednesday Thursday
Friday
Total
317
326
2 Roses
352
276
297
132
114
3 Pansies
153
126
111
79
95
4 Mums
98
112
87
5 Total
9. Insert a new row before the Total row and name it Daisies
with the following data: 56, 62, 47, 49, 53

(right-click the row 5 heading and select Insert, OR select row 5 and from the Insert menu select Rows)
10. AutoFit and resize rows and/or columns as needed. (double-click right margin of column in heading row)

Create a Formula
1.

Sum the days (columns) and products (rows).

(select cells B6 through E6 and click the AutoSum button)
(select cells G2 through G5 and click the AutoSum button)
2.
3.
A
1 Products

In column H, add the heading Average and average each product for the week.
(=AVERAGE(B2:E2), then use the AutoFill handle (black cross) to fill down to cell H5)
In column I, add the heading Percent and find the percent of sales for each product.
(=G2/$G$6, then use the AutoFill handle (black cross) to fill down to cell I5)
B

C

Monday

Tuesday

D

E

Wednesday

E

Thursday

G

Friday

Total

H
Average

I
Percent

2 Roses

352

276

297

317

326

=SUM(B2:E2) =AVERAGE(B2:E2)

=G2/$G$6

3 Pansies

153

126

111

132

114

=SUM(B3:E3) =AVERAGE(B3:E3)

=G3/$G$6

98

112

87

79

95

=SUM(B4:E4) =AVERAGE(B4:E4)

=G4/$G$6

56

62

47

49

53

=SUM(B5:E5) =AVERAGE(B5:E5)

=G5/$G$6

4 Mums
5 Daisies
6 Total

=SUM(B2:B5) =SUM(C2:C5) =SUM(D2:D5)

Format the Spreadsheet
1. Format the first and last rows as currency and the
remaining rows with comma style.

(select cells B2:H2, then hold CTRL and select
cells B6:H6. Click the Currency Style button)
(select cells B3:H5. Click the Comma Style
button)
2. Format the percent column as a percent.

(select cells I2:I5. Click the Percent Style button)
3. Format the spreadsheet with color, borders,
shading, etc. (select the entire spreadsheet, then

from the Format menu, select AutoFormat)

=SUM(E2:E5) =SUM(F2:F5) =SUM(B6:E6) =AVERAGE(B6:E6)

Print Options
1. Print preview the spreadsheet.
2. Set up margins, layout and scaling. (Click Setup in Print Preview. On

the Page tab, adjust scaling and orientation. On the Margins tab, adjust
margins and page alignment.)
3. Create a header with the workbook’s name and worksheet’s name.

(Click Setup in Print Preview. On the Header/Footer tab, click the
Customer Header button. Click the File button and Tab button. Click
the Date button.)
4. Create a footer with the date the report was printed.

(From the File menu, select Page Setup OR click the Setup button in
Print Preview. On the Header/Footer tab, click the Customer Footer
button. Click the Date button.)

